Skip to main content
← All vulnerabilities
CVE-2026-61397

Apache CloudStack: OAuth2 Token Cross-Request Leak

Published
Last modified
published
Not listed in CISA KEV
Critical (apache)
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: partial

Summary

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache CloudStack's OAuth2 authentication plugin and Google OAuth integration. This issue affects Apache CloudStack: from 4.19.0.0 through 4.20.3.0 and from 4.21.0.0 through 4.22.1.0. Users are recommended to upgrade to version 4.20.3.1 or 4.22.1.1, which fixes the issue.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: partial

  3. Record last updated

Affected versions

  • Apache Software Foundation Apache CloudStack

    From 4.19.0.0 · through 4.20.3.0; From 4.21.0.0 · through 4.22.1.0

References 1

lists.apache.org