Skip to main content
← All vulnerabilities
CVE-2026-59799

Apache CloudStack: Missing Privilege Check in Two-Factor Authentication Disable Flow

Published
Last modified
published
Not listed in CISA KEV
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

Improper Privilege Management vulnerability in Apache CloudStack's Two-factor authentication plugin allowing bypass of the two-factor authentication disable flow. This issue affects Apache CloudStack: from 4.18.0.0 through 4.20.3.0 and from 4.21.0.0 through 4.22.1.0. Users are recommended to upgrade to version 4.20.3.1 or 4.22.1.1 or later, which fixes the issue.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • Apache Software Foundation Apache CloudStack

    From 4.18.0.0 · through 4.20.3.0; From 4.21.0.0 · through 4.22.1.0

References 1

lists.apache.org