Skip to main content
← All vulnerabilities
CVE-2026-58178

Apache Traffic Server: ESI plugin allows uncontrolled recursion and server-side request forgery

Published
Last modified
published
Not listed in CISA KEV
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: partial

Summary

The Apache Traffic Server ESI plugin can recurse without bound and fetch attacker-controlled URLs. This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.14, from 10.0.0 through 10.1.3. Users are recommended to upgrade to version 9.2.15 or 10.1.4, which fix the issue.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: partial

  3. Record last updated

Affected versions

  • Apache Software Foundation Apache Traffic Server

    From 8.0.0 · through 8.1.11; From 9.0.0 · through 9.2.14; From 10.0.0 · through 10.1.3

References 1

lists.apache.org