Skip to main content
← All vulnerabilities
CVE-2026-55955

Apache Tomcat: EncryptInterceptor not protected against replay attacks

Published
Last modified
published
Not listed in CISA KEV
Low (apache)
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Improper Authentication vulnerability in Apache Tomcat allowed a replay attack against the EncryptionInterceptor in the cluster component. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.22, from 10.1.0-M1 through 10.1.55, from 9.0.13 through 9.0.18, from 8.5.38 through 8.5.100, from 7.0.100 through 7.0.109. Users are recommended to upgrade to version 11.0.23, 10.1.56, 9.0.119, which fixes the issue.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Apache Software Foundation Apache Tomcat

    From 11.0.0-M1 · through 11.0.22; From 10.1.0-M1 · through 10.1.55; From 9.0.13 · through 9.0.118; From 8.5.38 · through 8.5.100; From 7.0.100 · through 7.0.109

References 1

lists.apache.org